Home | Community | Message Board


Edabea
Please support our sponsors.

General Interest >> Science and Technology

Welcome to the Shroomery Message Board! You are experiencing a small sample of what the site has to offer. Please login or register to post messages and view our exclusive members-only content. You'll gain access to additional forums, file attachments, board customizations, encrypted private messages, and much more!

PhytoExtractum Shop: Maeng Da Thai Kratom Leaf Powder

Jump to first unread post. Pages: 1
InvisibleAlteredAgain
Visual Alchemist
 User Gallery


Registered: 04/27/06
Posts: 11,171
Loc: Solar Circuit
Audio Problem in Linux (Ubuntu)
    #7134905 - 07/05/07 11:42 PM (13 years, 7 months ago)

i know there are a quite a few members on the shroomery who are familiar with linux.

well i finally decided to try it out. i installed Ubuntu 7.04 the other night with little to no trouble and i am actually very content with the OS in general.

however the only thing is that i can't get the sound working. :frown:

i am using an Intel sound card with a Realtek ALC861 chip. the system recognizes the card, so it seems to be a driver problem.

being a complete noob to the world of linux i don't really know how to go about solving this problem.

i've surfed many many forums in search for help and most people were telling me to install the "hda-intel" module, others were saying that there are currently no compatible Realtek drivers for Ubuntu, so i'm just really confused.

i need some help. if i can't get the sound to work i'm unfortunately going to be forced to switch back to windows xp again.


--------------------


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
Invisiblesupercollider
superconducting


Folding@home Statistics
Registered: 10/14/00
Posts: 1,234
Loc: Waxahachie
Re: Audio Problem in Linux (Ubuntu) [Re: AlteredAgain]
    #7135545 - 07/06/07 02:12 AM (13 years, 7 months ago)

What have you tried, what are the symptoms? How do you know the system recognizes the card?


--------------------
Supercollider? I just met her!


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
Offlinedelta9
Active Ingredient
Male

Registered: 10/29/04
Posts: 5,390
Loc: California
Last seen: 10 years, 4 months
Re: Audio Problem in Linux (Ubuntu) [Re: AlteredAgain]
    #7136028 - 07/06/07 06:40 AM (13 years, 7 months ago)

In addition to the above questions, we require output from the following:
Code:
lspci


Code:
groups


Code:
uname -a



Also, we need to know if you are using ALSA or OSS or what. Make sure groups shows you are in the audio group or you won't be allowed to use audio devices.


--------------------
delta9


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
InvisibleAlteredAgain
Visual Alchemist
 User Gallery


Registered: 04/27/06
Posts: 11,171
Loc: Solar Circuit
Re: Audio Problem in Linux (Ubuntu) [Re: delta9]
    #7136726 - 07/06/07 12:15 PM (13 years, 7 months ago)

okay, here's the output from lspci

Code:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7400 (rev a1)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
07:03.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
07:03.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
07:03.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
07:03.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
07:03.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)



groups

Code:
alexander adm dialout cdrom floppy audio dip video plugdev scanner netdev lpadmin powerdev admin



and uname -a

Code:
Linux Yellow7Star 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux



i'm pretty sure i'm using ALSA right now. when i go to volume control it shows me that my current device is HDA-Intel (Alsa-Mixer).

also

from what i've picked up so far, my alsa driver is currently alsa-driver-1.0.14.rc2. some people have been saying to update the driver to alsa-driver-1.0.14.rc4 to get my sound to work. however i have no clue as to how to go about doing that. :justdontknow:


--------------------


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
Offlinedelta9
Active Ingredient
Male

Registered: 10/29/04
Posts: 5,390
Loc: California
Last seen: 10 years, 4 months
Re: Audio Problem in Linux (Ubuntu) [Re: AlteredAgain]
    #7140965 - 07/07/07 05:20 AM (13 years, 7 months ago)

Your audio device is indeed detected by the system ( 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02) ) and it is indeed an Intel device. The HDA Intel driver for ALSA should be utilizing it. You are in the audio group. Make sure the volumes in the mixer are up and that the master volume and/or the PCM volume are not MUTED. Typically, by default, they start out muted.

This search or similar may help you update/install ALSA


--------------------
delta9


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
InvisibleAlteredAgain
Visual Alchemist
 User Gallery


Registered: 04/27/06
Posts: 11,171
Loc: Solar Circuit
Re: Audio Problem in Linux (Ubuntu) [Re: delta9]
    #7146077 - 07/08/07 01:30 PM (13 years, 7 months ago)

i found the solution to my problem the other day.

first open alsa-configuration.txt and scroll down until i spot the name of my sound card, then see what model i have (asus).

after that i went to edit alsa-base

Code:
sudo gedit /etc/modprobe.d/alsa-base



and add the following line at the end of the file

Code:
options snd-hda-intel model=asus



reboot. works. :smile:


--------------------


Post Extras: Filter  Print Post  Remind Me! Notify Moderator
Jump to top. Pages: 1

PhytoExtractum Shop: Maeng Da Thai Kratom Leaf Powder

General Interest >> Science and Technology

Similar ThreadsPosterViewsRepliesLast post
* K7S5A Audio problems shroom_muncher 544 1 06/23/04 12:39 AM
by zeta
* .linux.
( 1 2 all )
Xochitl 3,722 26 09/20/03 01:11 PM
by debianlinux
* linux monoamine 1,797 14 10/19/02 10:55 AM
by BuzzDoctor
* For anyone looking to try linux as a desktop OS
( 1 2 all )
windex 5,332 37 02/07/03 02:32 AM
by Malformed
* about to install ubuntu!
( 1 2 3 all )
Krishna 5,053 55 12/07/05 03:52 PM
by Krishna
* Just installed ubuntu
( 1 2 3 all )
Jim 3,380 40 02/03/06 01:40 PM
by Vvellum
* Ubuntu is a faggot cock sucking fuck bitch whore
( 1 2 all )
Fungi_x
4,601 20 04/28/06 10:14 PM
by Vvellum
* Best Linux/Unix Distribution? *DELETED*
( 1 2 3 all )
T0aD 5,222 52 07/06/04 05:48 PM
by tomu

Extra information
You cannot start new topics / You cannot reply to topics
HTML is disabled / BBCode is enabled
Moderator: trendal, automan
910 topic views. 0 members, 0 guests and 3 web crawlers are browsing this forum.
[ Print Topic ]
Search this thread:
Shroom Supply
Please support our sponsors.

Copyright 1997-2021 Mind Media. Some rights reserved.

Generated in 0.049 seconds spending 0.011 seconds on 16 queries.